How to draw Alien vs Predator Characters

how to make an alien character and how to get alien character in castle crashers and how to create alien characters
Dr.MohitBansal Profile Pic
Dr.MohitBansal,Canada,Teacher
Published Date:26-10-2017
Your Website URL(Optional)
Comment
Alien Character – Base Mesh Creation and Sculpting In this chapter, you will discover a new way of modeling 3D objects with the powerful sculpting tools of Blender. We will start with an overview of the sculpting process including brush settings and how to optimize the viewport. We will then create a base mesh with an amazing tool that Blender offers called the Skin modifier, which follows the concept art of an alien character. Afterwards, we will sculpt the character using the tools that we had previously introduced and learn more about their usage in the different cases that are required for our character. As sculpting is an artistic process, you will also learn about proportions and anatomy. Let's jump to another planet This chapter will cover the following topics: • Understanding the sculpting process • Optimizing the viewport • Learning about and using brushes • Creating a base mesh with the Skin modifier • Using Dyntopo • Understanding the basics of anatomy and proportions 53 Alien Character – Base Mesh Creation and Sculpting You will start the sculpting of the following alien character (shown on the right) using a sketch as a reference (shown on the left). This is done with Krita (an open source tool for 2D art). Understanding the sculpting process Before starting to sculpt our alien, we will take some time to understand what this means and what the advantages are of using this modeling method. We will then give an overview of the basic tools that Blender has to offer. An introduction to sculpting Before the introduction of sculpting in the 3D world, there was only the polygonal modeling method (the method that we've used in the second chapter) that takes more time when creating organic shapes. The goal of sculpting is to have more freedom while modeling. The process looks a little bit like real sculpting art, but in this case we sculpt over a 3D mesh (our digital clay). When sculpting in Blender, we use brushes as tools that act on the mesh. There are many brushes that have different behaviors such as digging, moving, or pinching. 54 Chapter 3 Choosing sculpting over poly modeling Sculpting allows us to think more about the shape of the object and less about its technical part, such as its topology. So, the goal of this method is to really concentrate on the design part of the object. We won't see the vertices, edges, or polygons. The technique is more efficient when the goal is to reach an organic object. When you model with the tools that we have previously shown to you (the poly modeling method) you need to keep the topology in mind while researching the shape, and it is even more complicated when you have finer details. So what if we want to have a good topology with a sculpture? We have to do a retopology, but you'll see this in the next chapter Using a pen tablet When we modeled the Robot Toy in the previous chapter, we used a mouse. While we are sculpting, it's pretty hard to use a mouse because it is not precise according to the process. This is why we use a pen tablet that gives the sensibility needed to get the right shape. It takes some time to get used to this, but with practice you will have more control over your sculpture. In order to navigate with the pen tablet in the 3D viewport, go to the User Preferences panel (Ctrl + Alt + U) and check the Emulate 3 Button mouse option. We will now be able to use the Alt key to navigate. Refer to Chapter 1, Straight into Blender for more precise details. It's also a good thing to check the Emulate Numpad option in order to be able to switch views with the keys that are above the QWERTY keys. A pen tablet with its stylus 55 Alien Character – Base Mesh Creation and Sculpting The sculpt mode In order to access all the tools needed for sculpting we need to go into the Sculpt Mode. The Sculpt Mode won't let us access the components of our mesh as in the Edit Mode, and we also won't be able to apply transformations on our objects as in the Object Mode. To switch to the Sculpt Mode, we select it in the drop-down menu located in the header of the viewport. As you can see, it is in the same place as the Edit Mode and the Object Mode. Optimizing the viewport Sculpting usually takes more resources than poly modeling because the number of polygons will quickly increase each time you want to add details. This is why we need to activate some settings that will boost our viewport. This is done as follows: 1. The first setting that we will check is located under the System tab in the User Preferences window (Ctrl + Alt + U) and it is called VBOs. It is used by OpenGL (the rendering API used by Blender) to better organize the data displayed on the screen. 2. In the Options tab, under the Options subpanel in the left panel of the viewport (in the Sculpt Mode), we will activate the Fast Navigate option. 3. We will also ensure that the Double Sided option is turned off. To do this, we can use a nice little add-on called Sculpt Tool. After the add-on is installed, on the Sculpt tab of the left panel of the viewport we now have the Double Sided Off option. Note that you can always access any option by pressing the Space key in the viewport and by typing the name of the tool that you want. 4. Later, when we sculpt our objects, we don't want to have something else other than our objects in the viewport. So we will deactivate the grid, the gizmos, and any other viewport information that we don't need. 5. In order to do this, we will go to the right panel of the viewport. We can open this by pressing the N key, and under the Display subpanel we will check the Only Render option. 6. By checking this option, we will simply deactivate all the options that are below the Only Render option, such as Outline Selected that consumes a lot of resources of the viewport. Remember this option as we will toggle it on or off depending on our needs. 56 Chapter 3 Anatomy of a brush As previously mentioned, we will use a lot of brushes that behave differently in order to sculpt our alien. In this section, we will take our hands over the settings that are shared between all the brushes with the Sculpt/Draw brush as an example. Let's perform the following set of steps: 1. In order to do our experimentation, we will use a Cube primitive. In the Object Mode, we place our cursor at the center of the scene (Shift + C) and we add a Cube (Shift + A). Note that you can use the one placed by default in any new scene if you want. 2. The Cube has a low polygonal resolution so we will have to subdivide it by going in to the Edit Mode, select all its components, and use the Subdivide Smooth option under the Specials menu (the W key). We will repeat this action six times in order to have a good density of polygons. 3. In the Sculpt Mode, we will then select the Standard brush (if not already selected) in the left panel of the 3D viewport by clicking on the brush icon button under the Tools tab (refer to 1 in the following screenshot). 4. We can now draw on the subdivided cube. As you can see, it pushes the geometry. This is because our brush has the Add option activated by default. If we want to go deeper, we will need to switch to the Subtract mode. The Subtract option simply reverses the behavior of the brush. Both the options are placed under the Brush subpanel in the Tools tab (refer to 2 and 3 in the following screenshot). It's not very convenient to click on buttons in order to do such a simple manipulation, so we encourage you to use the Ctrl key while sculpting on your mesh to switch between these modes. 5. As you may have seen, we are not really precise because of the size of our brush. 6. In order to change the size, we will use the corresponding slider under the brush icon called Radius (refer to 4 in the following screenshot ). We can (and recommend this to you) use the F key as a shortcut. 57 Alien Character – Base Mesh Creation and Sculpting 7. Now that we have more control over the size of our brush, we will change its Strength under the Radius slider (refer to 5 in the following screenshot). We can use the Shift + F key as a shortcut. As you can see, on the right-hand side of both sliders (Strength and Radius), there is a little icon that allow us to use the pen tablet sensitivity in order to dynamically change these options. We will only use this for the Strength option, so when we lightly press on the pen tablet, we will have less strength than if we were pressing it harder. Brush options 8. Another interesting thing that we can set for our brushes is Texture (also called an alpha). An alpha is usually a black and white image that is useful while adding details such as skin pores or patterns to an object. When an alpha is added to a brush, the black pixels will remove the brush behavior during sculpting. To import an alpha, we will first need to go in the Textures subpanel of the Properties panel (on the far left of the interface, by default) and click on the third icon (a checker pattern) (refer to 1 in the following screenshot). 9. We can now add a new texture, and under the Image subpanel, we can open an image. We can now go under the Textures subpanel of the Tools tab in order to select our newly imported texture (refer to 2 in the following screenshot). 10. If we want, we can also change the repetition of our alpha by changing the X, Y, and Z size sliders (refer to 3 in the following screenshot). 58 Chapter 3 Adding a Texture (alpha) to our brush 11. The last setting that we will test is the Curve profile of our brush. The curve of the brush is located under the Curve subpanel in the Tools tab. Changing the curve profile allows us to change the behavior of the brush. For instance, with our current brush, Sculpt/Draw, if we click on the last icon (the flat curve) under the curve, we can see that the brush is harder while sculpting over our cube. 12. To understand this setting better, imagine that this is half of the profile of a real brush (see the following screenshot). We can select each point that composes the curve and move it to change the curve profile. We can also add a new point on the curve by clicking anywhere on it. When a point is selected, we can remove it by clicking on the X button. This curve is called a Bezier curve, so we can also change the smoothness of a point using the Tool icon and choosing the handle type that we want. A modified curve of a brush. 59 Alien Character – Base Mesh Creation and Sculpting Dyntopo versus the Multires modifier In order to test our brush settings, we subdivided our cube by hand but it's not practical while sculpting an object because we didn't have enough control over the subdivision. In order to have control over our mesh, Blender gives us two main methods, the Multires (a.k.a. Multiresolution) modifier and Dyntopo. First touch with the Multires modifier The Multires modifier is added to the modifier stack of an object and allows us to maintain subdivision levels of sculpture. For instance, we can sculpt at a low level (with a low resolution), and the details will be transferred to the higher levels and vice versa. We will test it right now This is done as follows: 1. We will first create a new Blender file (by navigating to File New) and then with the default cube selected, we will go to the Properties panel in order to add a Multires modifier. 2. We will subdivide our cube six times with the Subdivide button (refer to 1 in the following screenshot). If we were using a Subdivision surface modifier, our cube will be rounder. To test this out, we can go into the sculpt mode and start sculpting our cube with the Draw brush. 3. We can now move between the different subdivision levels with the Sculpt slider of the Multires modifier (refer to 2 in the following screenshot). As you can see, we don't lose our sculpted information while changing levels, we are just changing the amount of details of the object. Of course, when you are at a lower level, you won't have as much detail as at the higher levels. The goal of all of this is to give you the possibility of changing the main shape of your sculpture at a low resolution without overwhelming yourself with all the details that you have sculpted at the higher levels. So don't try to add details too early in order to get the shape right and progressively increase the subdivisions. 60 Chapter 3 The Multires modifier with an example of three different levels of subdivisions First touch with Dyntopo The Dyntopo method will generate details according to the amount that we choose. The geometry will be subdivided when we sculpt an object and will be located where we have placed our mouse pointer. We will be using this method for our alien soon, so let's test this to get used to it: 1. We will first create a new Blender file (by navigating to File New). 2. The cube is a little bit low in resolution, so we will subdivide it twice with the Subdivide Smooth option (the W key). 3. In the Tools tab, under the Dyntopo subpanel, we can activate Dyntopo by clicking on the Enable Dyntopo button. Our cube will now be converted to triangles (this is not a problem because remember, while sculpting an object, we don't care about its topology, we care about its shape). If you want to look at the wireframe of the object, use the Z key or simply go into the Edit Mode. 4. By default, we are in Relative Details as you can see in the second drop-down menu. This option means that the amount of detail will be proportional to the distance of your working camera view. If we sculpt near the object, the amount of detail will be much more important than if we sculpt far from the object. 61 Alien Character – Base Mesh Creation and Sculpting 5. This method is nice, but there is another method that allows us to control the amount of detail without caring about our distance from the object. This is the constant details option (we will use this one for the alien). We can change from Relative details to Constant Details in the Sculpt details drop-down menu. The Dyntopo settings 6. As you can see, we now have the detail size slider expressed by a percentage that allows us to change the amount of detail that our brush will generate on our mesh. With a small percentage, we will have finer details and vice versa. A Dyntopo mesh with different levels of sculpted details. 62 Chapter 3 Creating a base mesh with the Skin modifier Before we sculpt our alien, we need to have a base mesh that has roughly its proportions. If you want, you can use the methods that you've learned in the previous chapter in order to model it, but here we are going to use a cool modifier that Blender has to offer: the Skin modifier. Its goal is to create a geometry around each vertex. We can simply extrude some vertices as if we were doing a real wire armature, and the Skin modifier will add volume around it. For each vertex, we have control over the volume size. Let's start our base mesh: 1. We will start by entering in to the Edit Mode of our default cube. Then we will select all the vertices (A) and merge them to a sole vertex at the center (press Alt + M and click on the center). We now have our root vertex that will be the pelvis of our alien. 2. It's now time to add a Skin modie fi r to our object in the modie fi r stack. As you can see, our vertex is controlling a new geometry around it. The geometry is low, so we will add a Subdivision surface modie fi r on top of the Skin modie fi r in order to have a smoother look. As you may have seen, the vertex has a red circle around it. This means that it is the root of our armature. 3. We can now extrude our vertex (E) on the Z axis in order to start the torso of our alien. 4. Now we will add a Mirror modifier with the Clipping option turned on. This modifier needs to be placed before the Skin and Subdivision Surface modifier (use the up and down arrows to move it to the first place). Ensure that the vertices that are on the symmetry axis are merged. 5. We can now select the top vertex (the base of the neck) and extrude it by pressing Ctrl and LMB to the right in order to create the shoulder. Be careful with the position of your vertex as the topology generated could be bad. Always try to move your vertices a little bit in order to see whether you can't have a better topology. 6. We will now change the size of the volume that has been generated around the shoulder vertex. To do this, we will use the Ctrl + A shortcut and we move our mouse to adjust it. 7. We will then extrude the arm. In order to give a more dynamic shape, we will bend it at the elbow. We then adjust its size. At this point, it is very important to match the proportions of the concept. Proportions means the length and size of the different members with respect to each other. If you need to constrain the size or change the volume on a certain axis, you can press Ctrl + A + X, Y, or Z. 63 Alien Character – Base Mesh Creation and Sculpting 8. Let's extrude the long neck of our alien. 9. It's now time to add the legs of our alien. We will do this by extruding the pelvis vertex at a 45 degree angle (press Ctrl and LMB). Then we extrude the leg and adjust its profile by changing the size of the different vertices (Ctrl + A). As we did for the arm, we will bend the leg a little bit at the knee location. Note that the pelvis vertex should be always marked as the root of the armature. If this is not the case, select it and in the Skin modifier , press the Mark Root button. 10. The foot will be then extruded and resized. We can create the heel by simply extruding the ankle vertex to the back. The ankle vertex needs to be marked as Loose in order to have a nice transition with the front and the heel of the foot. To do this, we select it and use the Mark Loose button in the Skin modifier. 11. It's now time to create the hand by extruding the wrist vertex. From the new vertex, we will extrude three fingers that will be rescaled appropriately. Note that the thumb is at a 45 degree angle from the other fingers. To add a more dynamic feeling to the hand, we will slightly bend the fingers inwards. 12. We will then extrude the base of the neck. From the newly created vertex, we can extrude the head vertex that will then be the base for the chin and the cranium. The steps of the base mesh creation with the Skin modifier. 13. We can now apply all our modifiers from the top to the bottom of the stack. 64 Chapter 3 14. If we enter in the Edit Mode, we can see that some parts are very dense. This is why we are going to remove some edge loops from certain parts such as the fingers. However, rather than doing this for both sides of the model, we are going to split the mesh in two and add a mirror modifier. To do this, we first need to ensure that there is a symmetry axis in the middle of our mesh. If this not the case, you can use the knife tool (K) to create it. Then we can delete half of our model and add a mirror modifier as we did in the previous chapter. We can now select some edge loops where there is a lot of condensed geometry by pressing Shift + Alt and the RMB, and by pressing X we can delete them (delete the edge loops, not the vertices or faces). Removing some edge loops of the dense parts. 15. The base mesh is now ready to be sculpted. The final base mesh 65 Alien Character – Base Mesh Creation and Sculpting Visual preparation While sculpting, it's nice to use Matcap. It is simply an image that will be projected on your mesh in the viewport and that looks like a material. For instance, you can use a Matcap that reminds you of clay. Let's begin with our sculpting: 1. To set up a Matcap for our mesh, we will have to set up the default material of our mesh in the Properties panel under the Material tab (refer to 1 in the following screenshot). Note that if you can't see a material, you can press the New button. 2. Now we will check the Shadeless option under the Shading subpanel (refer to 1 in the following screenshot). Creation of a new material with the Shadeless option. 3. As we have said before, a Matcap is an image, so we will import our image as the texture of our material. To do this, we go to the Texture tab (refer to 3 in the following screenshot) and we add a new texture by clicking on the New button. In the image subpanel, we will click on the Open button (refer to 4 in the following screenshot) and we choose our Matcap image. 66 Chapter 3 4. A Matcap is mapped to a mesh according to its normals, so in the Mapping subpanel change the Coordinates from UV to Normals (refer to 5 in the following screenshot). We will also adjust the size of our projection by decreasing the X, Y, and Z size sliders to 0.95 (refer to 6 in the following screenshot). Setting the Matcap image texture for our material 5. In order to see our Matcap in the viewport, we will replace the Multitexture display mode with GLSL in the right panel of the 3D view (N) under the Shading subpanel. 67 Alien Character – Base Mesh Creation and Sculpting 6. Last but not least, we will go into the Shading mode under Texture Viewport using the corresponding drop-down menu in the 3D view header. You can also use the Alt + Z shortcut to quickly switch to this mode. Our Matcap is now perfectly set up Setting the GLSL display mode in the right panel of the viewport (N). An introduction to artistic anatomy Before continuing with the alien creation, some basic knowledge of anatomy can be very useful. It is a basic discipline for a character artist. Don't worry, we will clarify the concerned parts of the body for each step with illustrations. Of course it is an alien, so we can accept the fact that we don't always have to respect human anatomy for specific parts. He has a huge head, only two n fi gers and a thumb, and very different feet. His humanoid appearance imposes some anatomical likelihood. This is especially useful if you plan to animate it later on. Improving your knowledge of this topic will help you to understand the movements and postures better. In the early 16th century, Leonardo Da Vinci was one of the first artists who tried to understand the human anatomy. While religious obscurantism prohibited the examination of corpses, he dared to defy this. By dissection and observation, he did many illustrations detailing the positioning of muscles, joints, nerves, and organs. It won't be necessary in our case to know the scientific names by heart. It's rather important to know and understand their general forms. Overall, it's more about the comprehension of human body mechanisms. 68 Chapter 3 Many good books treat this subject. For more information, you can have a look at these websites: • http://md3dinc.com/ • https://www.anatomy4sculptors.com/ • http://www.3d.sk/ Sculpting the body We are continuing the modeling of our alien using Dyntopo as we had previously mentioned. This will allow the creation of the antennae very easily while they are not yet present in the base mesh. The following is the preparation of our environment before sculpting: 1. We will set the optimizing options that were previously explained. 2. We can adjust the lens parameter in the right panel of the 3D viewport (N). A high value lessens the focal deformations. 3. We must check the mirror options in the left panel of the 3D viewport (T) to Symmetry/Lock by choosing the axis of symmetry. It is very important in order to save time. 4. We will then activate the Dyntopo option in the left panel of the viewport. A detail size of around 25 percent is enough to start. It depends on the size of your model. For a better understanding, we are going to start sculpting by adding details by iteration. The head We start defining the jaw and chin with the Clay Strips brush (refer to 1 in the following screenshot). It is unnecessary to have too many details for the moment. While sculpting, always remember to define the main shapes (the volumes) and then gradually move towards the details. We then accentuate the delimitation between the jaw and neck without exaggeration. A strength of 0.5 is enough. 69 Alien Character – Base Mesh Creation and Sculpting The Clay Strips brush The Clay Strips brush is a very useful brush to define muscles, dig or add polygons in a straight direction with pretty sharp outlines. It is the equivalent of the Clay Buildup in Zbrush. 1. In order to dig into the polygons, we press Ctrl while sculpting. It allows us to switch to the Subtract mode on the fly. 2. Then we slightly smooth the added geometry with the Smooth brush for a better blend of the created shape. You need to remember to smooth the shape very often in order to avoid having something too grainy. 70 Chapter 3 The Smooth brush This is often a very useful brush. It allows you to soften and smooth your shapes. This brush is so useful that there is a special shortcut that you absolutely need to know. Hold the Shift key while sculpting in order to use it. It works while using any brush. When you use it over a big density of polygons, it will be harder to smooth your shape, so it will be mainly useful before working on the details. 3. Now that the jaw is sketched, we will go to the side view. Then we have to adjust the silhouette of the neck, as well as the skull with the Grab brush. Our alien has a very curved neck. 4. We will adjust the shape of our model little by little by turning it around. It's very important to observe your model from different points of view. Do not hesitate a moment to look at the reference sketch and position the alien in a very similar pose. You can also create a new 3D view editor to keep an eye on the view of your choice (in our case, we've used the orthographic side view). The Grab brush This is often a very useful brush when you start a new model. It works a little bit in the same way that the Proportional Editing tool does. If you have any difficulties using it, you can go to the Curve options in the left panel of the viewport and modify the curve to decrease its profile. 71 Alien Character – Base Mesh Creation and Sculpting In our case, we are going to use a very soft curve for the Smooth brush. 1. Again, we will take the Clay Strips brush to keep going on the face of the alien in order to dig the orbits and accentuate the eyebrows by adding matter (refer to 2 and 3 in the previous screenshot). Be careful to not add too much volume at this place. Do not hesitate to decrease the strength (Shift + F) of your brush, if necessary. 72