Mercury QuickTest Professional Tutorial

mercury quick test professional 9.2 free download and mercury quicktest professional user guide and 9.2 crack and mercury interactive quicktest
Prof.WilliamsHibbs Profile Pic
Prof.WilliamsHibbs,United States,Teacher
Published Date:28-07-2017
Your Website URL(Optional)
Comment
1 Introducing QuickTest In this lesson you will learn about the: ➤ Benefits of Automated Testing ➤ Testing Process ➤ QuickTest Window ➤ Mercury Tours Sample Web Site Benefits of Automated Testing If you have ever tested applications or Web sites manually, you are aware of the drawbacks. Manual testing is time-consuming and tedious, requiring a heavy investment in human resources. Worst of all, time constraints often make it impossible to manually test every feature thoroughly before the application is released. This leaves you wondering whether serious bugs have gone undetected. Automated testing with QuickTest addresses these problems by dramatically speeding up the testing process. You can create tests that check all aspects of your application or Web site, and then run these tests every time your site or application changes. 1Lesson 1 • Introducing QuickTest As QuickTest runs tests, it simulates a human user by moving the mouse cursor in a Web page or application window, clicking Graphical User Interface (GUI) objects, and entering keyboard input; however, QuickTest does this faster than any human user. Benefits of Automated Testing Fast QuickTest runs tests significantly faster than human users. Reliable Tests perform precisely the same operations each time they are run, thereby eliminating human error. Repeatable You can test how the Web site or application reacts after repeated execution of the same operations. Programmable You can program sophisticated tests that bring out hidden information. Comprehensive You can build a suite of tests that covers every feature in your Web site or application. Reusable You can reuse tests on different versions of a Web site or application, even if the user interface changes. Testing Process The QuickTest testing process consists of 7 main phases: 1 Preparing to record Before you record a test, confirm that your application and QuickTest are set to match the needs of your test. Make sure your application displays elements on which you want to record, such as a toolbar or a special window pane, for example, and that your application options are set as you expect for the purposes of your test. You should also view the settings in the Test Settings dialog box (Test Settings) and the Options dialog box (Tools Options) to ensure that QuickTest will record and store information appropriately. For example, you should confirm that the test is set to use the appropriate object repository mode. 2Lesson 1  Introducing QuickTest 2 Recording a session on your application As you navigate through your application or Web site, QuickTest graphically displays each step you perform as a row in the Keyword View. A step is any user action that causes or makes a change in your application, such as clicking a link or image, or entering data in a form. 3 Enhancing your test ➤ Inserting checkpoints into your test lets you search for a specific value of a page, object, or text string, which helps you determine whether your application or site is functioning correctly. ➤ Broadening the scope of your test, by replacing fixed values with parameters, lets you check how your application performs the same operations with multiple sets of data. ➤ Adding logic and conditional or loop statements enables you to add sophisticated checks to your test. 4 Debugging your test You debug a test to ensure that it operates smoothly and without interruption. 5 Running your test You run a test to check the behavior of your application or Web site. While running, QuickTest opens the application, or connects to the Web site, and performs each step in your test. 6 Analyzing the test results You examine the test results to pinpoint defects in your application. 7 Reporting defects If you have Quality Center installed, you can report the defects you discover to a database. Quality Center is Mercury Interactive’s software test management tool. 3Lesson 1  Introducing QuickTest QuickTest Window Before you begin creating tests, you should familiarize yourself with the main QuickTest window. The image below shows a QuickTest window as it would appear after you record a test, with all toolbars and panes (except the Debug Viewer pane) displayed: Title bar Menu bar File toolbar Debug toolbar Testing toolbar Action toolbar Test pane Data Table Status bar Active Screen 4Lesson 1  Introducing QuickTest The QuickTest window contains the following key elements: ➤ Title bar—Displays the name of the currently open test. ➤ Menu bar—Displays menus of QuickTest commands. ➤ File toolbar—Contains buttons to assist you in managing your test. Open Print Data Results Options Object Table Repository Debug Quality New Save Active Test Object Viewer Center Screen Settings Spy Connection ➤ Testing toolbar—Contains buttons to assist you in the testing process. Start Split Analog Transaction Record Stop Action Recording Low-Level Start New Insert End Run Action Checkpoint Transaction Recording ➤ Debug toolbar—Contains buttons to assist you in debugging tests. Step Step Clear All Out Breakpoints Into Pause Step Insert/Remove Over Breakpoint Note: The Debug toolbar is not displayed when you open QuickTest for the first time. You can display the Debug toolbar by choosing View Toolbars Debug. Note that this tutorial does not describe how to debug a test. For additional information, refer to the QuickTest Professional User’s Guide. 5Lesson 1  Introducing QuickTest ➤ Action toolbar—Contains buttons and a list of actions, enabling you to view the details of an individual action or the entire test flow. Action List Display selected action Back Note: The Action toolbar is only displayed in the Keyword View. It is not displayed when you open QuickTest for the first time. You can display the Action toolbar by choosing View Toolbars Action. If you insert a reusable or external action in a test, the Action toolbar is displayed automatically in the Keyword View. For additional information, refer to the QuickTest Professional User’s Guide. ➤ Test pane—Contains the Keyword View and Expert View tabs. ➤ Active Screen—Provides a snapshot of your application as it appeared when you performed a certain step during the recording session. ➤ Data Table—Assists you in parameterizing your test. ➤ Debug Viewer pane—Assists you in debugging your test. The Debug Viewer pane contains the Watch Expressions, Variables, and Command tabs. (The Debug Viewer pane is not displayed when you open QuickTest for the first time. You can display the Debug Viewer by choosing View Debug Viewer.) ➤ Status bar—Displays the status of the QuickTest application. The buttons used in the File and Testing toolbars are described in detail in subsequent lessons. The buttons used in the Debug toolbar are described in detail in the “Debugging Tests” chapter in the QuickTest Professional User’s Guide. The Action toolbar is described in Lesson 8, “Dividing Tests into Multiple Actions.” Note that you can also execute many menu commands using shortcut keys. For additional information, see the “QuickTest at a Glance” chapter in the QuickTest Professional User’s Guide. 6Lesson 1  Introducing QuickTest Now that you are familiar with the main QuickTest window, take a few minutes to explore its components. Mercury Tours Sample Web Site Mercury Tours is the sample Web application used throughout this tutorial. It simulates a Web-based flight information and reservation service. You should familiarize yourself with this application before starting the tutorial. Optimizing Browser Settings for Your Test If you are using Internet Explorer as your browser, you should clear the option to use AutoComplete for user names and passwords for the purposes of this tutorial. This will ensure that all of your operations are accurately recorded while creating your tests. To clear the AutoComplete option: 1 In your Internet Explorer’s menu bar, choose Tools Internet Options Content tab. 2 Click AutoComplete in the Personal information area. The AutoComplete Settings dialog box opens. 3 In the Use AutoComplete for area, clear the User names and passwords on forms option. 4 Click OK to save your changes and close the AutoComplete Settings dialog box, then click OK again to close the Internet Options dialog box. Using the Mercury Tours Web Site for the First Time Before you begin recording your tests on the Mercury Tours Web site, you must register as a user. To run Mercury Tours: 1 Launch the Mercury Tours application. In your Web browser, type the following URL: http://newtours.mercuryinteractive.com The Mercury Tours home page opens. 7Lesson 1  Introducing QuickTest 2 Register with Mercury Tours. To log-in and use the Mercury Tours application, you must be a registered user. From the home page, click the REGISTER navigation button. The Register page opens. In the User Information section at the bottom of the page, enter any user name and password, and confirm your password. (Other information is not required.) Click SUBMIT. Mercury Tours confirms your registration. From this confirmation page, click the SIGN-ON navigation button to enter the application. The Sign-on page opens. Enter your registered user name and password, and click SUBMIT. The Flight Finder page opens. 3 Explore the Mercury Tours site. Beginning with the Flight Finder page, follow the on-screen instructions to get flight information and reserve a flight. Note that on the Book a Flight page, you do not have to fill out actual personal or credit card information; just enter the required information (indicated by red) in the Passengers and Credit Card sections. (You may enter fictitious information.) 4 End your Mercury Tours session. When you are done exploring the Mercury Tours application, click the LOG OUT button on the Flight Confirmation page or the SIGN-OFF link at the top of any application page. To sign-in again, simply enter your registered user name and password in the Sign-on page or in the Mercury Tours home page. 5 Close the Web browser. You are now ready to begin using this tutorial to create tests on the Mercury Tours application using QuickTest 82 Recording Tests As you navigate through your Web site or application, QuickTest records your steps. These operations are the basis of your test. When you stop recording, you can see the steps of your newly-created test in a graphical format in the Keyword View. In this lesson you will learn about: ➤ Preparing to Record a Test ➤ Recording a Test ➤ Analyzing the Test in the Keyword View Preparing to Record a Test Before you begin recording a test, ensure that both your application or Web site and QuickTest are set to match the needs of your test. For the purposes of this tutorial, ensure that: ➤ You have registered as a user in the Mercury Tours Web site. For more information, see “Using the Mercury Tours Web Site for the First Time” on page 7. ➤ If you are using Internet Explorer as your browser, the AutoComplete option is cleared for user names and passwords. For instructions, see “Optimizing Browser Settings for Your Test” on page 7. ➤ All browsers are closed before you begin recording. 9Lesson 2  Recording Tests Recording a Test In this section, you will record the process of making a reservation for a flight from New York to San Francisco on the Mercury Tours Web site. 1 Start QuickTest and open a new test. ➤ If QuickTest is not currently open, choose Start Programs QuickTest Professional QuickTest Professional. In the Add-in Manager, confirm that the Web Add-in is selected, and clear all other add-ins. Click OK to close the Add-in Manager and open QuickTest. Note: While QuickTest loads your selected add-ins, the QuickTest splash screen is displayed. This may take a few seconds. If the Welcome window opens, click Blank Test. Otherwise, choose File New, or click the New button. A blank test opens. ➤ If QuickTest is already open, check which add-ins are loaded by selecting Help About QuickTest Professional. If the Web Add-in is not loaded, you must exit and restart QuickTest. When the Add-in Manager opens, select the Web Add-in, and clear all other add-ins. Choose File New, or click the New button. A blank test opens. Note: If the Add-in Manager does not open when starting QuickTest, choose Tools Options. In the General tab, select Display Add-in Manager on startup. When you exit and restart QuickTest, the Add-in Manager opens. 10Lesson 2  Recording Tests 2 Start recording on the Mercury Tours Web site. Choose Test Record or click the Record button. The Record and Run Settings dialog box opens. ➤ In the Web tab, select Open the following browser when a record or run session begins. Choose a browser from the Type list and confirm that the URL in the Address box is http://newtours.mercuryinteractive.com. Confirm that Close the browser when the test closes and Do not record and run on browsers that are already open are selected. 11Lesson 2  Recording Tests ➤ In the Windows Applications tab, confirm that Record and run on these applications (opened on session start) is selected, and that there are no applications listed. This setting prevents you from inadvertently recording operations performed on various Windows applications (such as e-mail) during a recording session. Click OK. QuickTest begins recording, and your browser opens to the Mercury Tours Web site. 3 Log in to the Mercury Tours Web site. In the User Name and Password boxes, type the name and password you registered with Mercury Tours. Click Sign-In. The Flight Finder page opens. 12Lesson 2  Recording Tests 4 Enter flight details. Change the following selections: ➤ Departing From: New York ➤ On: Dec 29 ➤ Arriving In: San Francisco ➤ Returning: Dec 31 ➤ Service Class: Business class Click CONTINUE to accept the other default selections. The Select Flight page opens. Notes: When selecting the date, you must click on the drop-down list, scroll to any entry that is not showing, and select it. This is because QuickTest only records a step if the value in the list changes. The tutorial will not work correctly if you accept the currently displayed month or day. When entering dates while recording this test, do not click the View Calendar button, which opens a Java-based calendar. Your test will not record the date selected using this calendar because the Java Add-in is not loaded for this tutorial (The Java Add-in is an external add-in that can be purchased separately.) To check which add-ins are loaded, click Help About QuickTest Professional. To change the available add-ins for your tests, you must close and reopen QuickTest Professional. 5 Select a flight. Click CONTINUE to accept the default flight selections. The Book a Flight page opens. 6 Enter required passenger and purchase information. Enter the required information (fields with red text labels) in the Passengers and Credit Card sections. (You may enter fictitious information.) 13Lesson 2  Recording Tests In the Billing Address section, select Ticketless Travel. At the bottom of the page, click SECURE PURCHASE. The Flight Confirmation page opens. 7 Review and complete your booking. Click BACK TO HOME. The Mercury Tours home page opens. 8 Stop recording. In QuickTest, click Stop on the Testing toolbar to stop the recording process. You have now reserved an imaginary business class ticket from New York to San Francisco. QuickTest recorded your Web browser operations from the time you clicked the Record button until you clicked the Stop button. 9 Save your test. Select File Save or click the Save button. The Save dialog box opens to the Tests folder. Create a folder named Tutorial, select it, and click Open. Type Recording in the File name field. Confirm that Save Active Screen files is selected. Click Save. The test name (Recording) is displayed in the title bar of the main QuickTest window. 14Lesson 2  Recording Tests Analyzing the Test in the Keyword View As you recorded your test, QuickTest generated steps in the Keyword View representing each operation you performed in the Web browser. The columns in the Keyword View show different information for each step, as follows: ➤ Item—Displays the item for the step (test object, utility object, function call, or statement) in a hierarchical icon-based tree. ➤ Operation—The operation to be performed on the item, for example, Click or Select. ➤ Value—The argument values for the selected operation, for example, the mouse button to use when clicking the image. ➤ Assignment—The assignment of a value to or from a variable so you can use the value later in the test. ➤ Comment—Any textual information you want to add regarding the step, for example, Return to page used in first step of the test. ➤ Documentation—Auto-documentation of what the step does, in an easy-to-understand sentence, for example, Click the “findFlights” image. Note: You can choose to hide or display individual columns as required, by right-clicking the column heading in the Keyword View and selecting a column name from the list. In the Item column of the Keyword View, you can click the branch arrows to expand or collapse the steps under each Web page. You can expand the entire test by choosing View Expand All. 15Lesson 2  Recording Tests When you expand your test, it should look similar to this: For every step performed on an object, QuickTest displays a row in the Keyword View with an icon and details of the step. For example, the step below instructs QuickTest to click the reserveFlights image at a specific location in the Select a Flight: Mercury page of the Mercury Tours Web site. 16Lesson 2  Recording Tests The table below provides an explanation of the first few steps shown in the test in the Keyword View above. Step Description Action1 is the action name. The browser invokes the Welcome: Mercury Tours Web site. Welcome: Mercury Tours is the name of the Web page. userName is the name of the edit box. Set is the method performed on the edit box. mercury is the value of the edit box. password is the name of the edit box. SetSecure is an encryption method performed on the edit box. 4082820183afe512e8bc91c1f7222dbd is the encrypted value of the password. Sign-In is the name of the image link. Click is the method performed on the image. 2, 2 are the x- and y-coordinates where the image was clicked. Take a few minutes to examine the Keyword View in detail, tracing the steps you performed while recording your test. For more information on the Keyword View, refer to the QuickTest Professional User’s Guide. 17Lesson 2  Recording Tests 183 Running and Analyzing Tests When you run your test, QuickTest opens the appropriate application or Web site and performs each step as it was originally recorded in the test. When QuickTest finishes running the test, it displays the results of the run. In this lesson you will learn about: ➤ Running a Test ➤ Analyzing Test Results Running a Test In this lesson, you will run the test you recorded in the previous lesson. 1 Start QuickTest and open the Recording test. If QuickTest is not already open, choose Start Programs QuickTest Professional QuickTest Professional. ➤ If the Welcome window opens, click Open Existing. ➤ If QuickTest opens without displaying the Welcome window, choose File Open or click the Open button. In the Open Test dialog box, locate and select the Recording test, then click Open. 19

Advise: Why You Wasting Money in Costly SEO Tools, Use World's Best Free SEO Tool Ubersuggest.