How to Create SAP Crystal Reports

how to install sap crystal reports 2013 and how to use sap crystal reports in asp.net and sap crystal reports benefits and sap crystal reports best practices
Prof.WilliamsHibbs Profile Pic
Prof.WilliamsHibbs,United States,Teacher
Published Date:28-07-2017
Your Website URL(Optional)
Comment
SAP Crystal Reports 2011 User's Guide ■SAPCrystalReports2011 2012-03-14Introduction to SAP Crystal Reports 2011 Introduction to SAP Crystal Reports 2011 1.1 About Crystal Reports SAP Crystal Reports 2011 (Crystal Reports) is designed to work with your database to help you analyze and interpret important information. Crystal Reports makes it easy to create simple reports, and, it also has the comprehensive tools you need to produce complex or specialized reports. Create any report you can imagine Crystal Reports is designed to produce the report you want from virtually any data source. Built-in report experts guide you step by step through building reports and completing common reporting tasks. Formulas, cross-tabs, subreports, and conditional formatting help make sense of data and uncover important relationships that might otherwise be hidden. Geographic maps and graphs communicate information visually when words and numbers are simply not enough. Extend reporting to the Web The flexibility of Crystal Reports doesn't end with creating reports — your reports can be published in a variety of formats including Microsoft Word and Excel, E-mail and even over the Web. Advanced Web reporting lets other members of your workgroup view and update shared reports inside their web browser. Incorporate reports into applications Application and web developers can save time and meet their users needs by integrating the report processing power of Crystal Reports into their database applications. Support for most popular development languages makes it easy to add reporting to any application. Whether it's the web master in IT, the promotion manager in marketing, the database administrator in finance or the CEO, Crystal Reports is a powerful tool designed to help everyone analyze and interpret the information that's important to them. 1.2 About the Crystal Reports documentation The Crystal Reports documentation includes procedures for typical reporting tasks such as placing fields, formatting reports, and sorting records. It also contains information on more specific areas of interest such as advanced formula creation and accessing different types of data. Use the documentation 21 2012-03-14Introduction to SAP Crystal Reports 2011 as a reference for your basic reporting needs as well as an introduction to new concepts in report creation. 1.2.1 Locate information quickly • Access online help from the Crystal Reports help menu. Use the Contents tab to view all major sections in the online help and drill down to specific headings within each section, the Index tab to view topics in alphabetical order, and the Search tab to enter a keyword to view all the sections that relate to the keyword. • Access a PDF version of the Crystal Reports documentation online at http://support.businessob jects.com/documentation. The PDF version contains a subset of the topics found in the online help, along with additional sections—such as a Quick Start—that can help you learn Crystal Reports. 1.2.2 Sample Reports Many topics in the Crystal Reports documentation include a list of related sample reports. Use these reports to illustrate concepts the topic describes. The sample reports can be adapted to your own needs. Sample reports are located on the SAP Business Objects Support web site. 22 2012-03-14Quick Start Quick Start 2.1 Learning how to use Crystal Reports You can teach yourself how to use Crystal Reports by choosing from the methods available in this section: • You can study the sample reports and sample database included with Crystal Reports. You will find the sample reports and sample database for Crystal Reports at the SAP Business Objects Support web site. • You can use the detailed descriptions and instructions in the Quick start for new users. • You can use the summaries and topic cross-references in the Quick start for advanced users—especially useful if you're already familiar with reporting concepts. Each method is a helpful way to learn and understand Crystal Reports and, although any one might be enough to get you up and running, you can always come back to this section and consult the other methods as you need them. 2.1.1 Sample data - Xtreme.mdb A sample database, Xtreme.mdb, is available for you to use while you are learning Crystal Reports. Xtreme.mdb is a Microsoft Access database and all of the necessary drivers are included. You should be able to open the database directly and begin designing reports. Virtually all of the examples in this manual are based on Xtreme.mdb data. Xtreme.mdb is located on the SAP Business ObjectsSupport web site. Xtreme.mdb is a database that contains data for Xtreme Mountain Bikes, a fictitious manufacturer of mountain bikes and accessories. Note: The sample data has been designed to illustrate various reporting concepts in a training environment, not to teach database design. While there are alternative ways of designing a database, this design was selected to keep the tutorials and examples focused on reporting, not on data manipulation. 23 2012-03-14Quick Start 2.2 Report Creation Wizards The tutorials in this section show you how to build a report from scratch. As a complement or an alternative, however, you may want to use the Report Creation Wizards available on the Start Page. There are four Report Creation Wizards: • Standard • Cross-Tab • Mailing Label • OLAP Each wizard guides you through the creation of a report by providing a series of screens. Many of the wizards have screens unique to a specific type of report. For example, the Mailing Labels Report Creation Wizard has a screen that allows you to specify the type of mailing label you want to use. Note: After you've clicked the Finish button in a Report Creation Wizard, you can click the Stop button on the Navigation Tools toolbar if you don't want the program to gather all the data from your data source. This is useful if you want to make adjustments to the report layout that the wizard created. 2.2.1 Standard The Standard Report Creation Wizard is the most generic of the wizards. It guides you through choosing a data source and linking database tables. It also helps you add fields and specify the grouping, summarization (totals), and sorting criteria you want to use. Finally, the Standard Report Creation Wizard leads you through chart creation and record selection. The Templates screen contains predefined layouts for you to apply to your report to give it more impact. 2.2.2 Cross-Tab The Cross-Tab Report Creation Wizard guides you through the creation of a report in which your data is displayed as a cross-tab object. Two special screens (Cross-Tab and Grid Style) help you create and format the cross-tab itself. 24 2012-03-14Quick Start 2.2.3 Mailing Label The Mailing Labels Report Creation Wizard lets you create a report that is formatted to print on any size mailing label. You can use the Label screen to select a commercial label type, or you can define your own layout of rows and columns for any multi-column style report. 2.2.4 OLAP The OLAP Report Creation Wizard lets you create a report in which your OLAP data is displayed as a grid object. Although similar to the Cross-Tab Report Creation Wizard in several ways, the OLAP Report Creation Wizard appears to be different due to the requirements of working with OLAP data sources. You first specify the location of your OLAP data, and then you choose the dimensions you want to include in the grid. Next you filter the report data and choose the style of the grid object, which you can also customize. Finally, you can define labels for your grid and insert a chart, if you wish. 2.3 Quick start for new users The following tutorial has been designed to give you confidence when creating your first report. In this tutorial, you will get an introduction to the program as you create a Customer List report. The Customer List is one of the most basic business reports and typically has information such as Customer Name, City, Region, and Contact Name. You begin by learning the basic concepts: selecting a database, placing some fields on the report, and then selecting specific records to be included. You will then learn how to: • Insert and move database fields. • Add and format a title. • Display a report in the Preview tab so you can fine-tune your work. • Use the Select Expert to ensure the report includes only the data you need. • Move objects. • Group and sort data. • Insert pictures. • Print a report. 25 2012-03-14Quick Start 2.3.1 Before you begin This tutorial assumes you are familiar with Microsoft Windows and uses conventional terms and procedures common to the Windows environment. If you are not familiar with Windows, please refer to the documentation that came with Microsoft Windows for further explanation. If you are not familiar with the Crystal Reports environment, review Formatting, which describes working with the grid, using guidelines, and formatting activities. 2.3.2 Creating the report 1. Click theStartPage tab if the Start Page is not already visible in Crystal Reports. 2. In the New area, clickFromDataSource. The Choose a Data Source Connection dialog box appears. Note: You can create reports based on database files, SQL/ODBC data sources, Business Views, and a variety of other data sources. 2.3.2.1 Selecting a database to use The next step in creating a report is to select a database. Use the Xtreme.mdb sample database for this tutorial. The Xtreme.mdb file is located on the SAP Business Objects Support web site. Copy Xtreme.mdb to a location on your machine that you can access for the tutorial. 2.3.2.1.1 To select a database 1. In the Database Expert dialog box, expand theCreateNewConnection folder and then expand theDatabaseFiles folder; then search for theXtreme.mdb sample database. Note: • You have to use the Open dialog box to find the Xtreme database. • If you wish to see database and server properties after you have selected a database, right-click the database node in the Database Expert and select Properties from the shortcut menu. 26 2012-03-14Quick Start 2. Expand theTables node of theXtreme.mdb connection to see a list of tables. Because you are dealing only with customers in this tutorial, you will select the Customer table. 3. Select Customer and click the arrow to add it to the Selected Tables list, and then clickOK. The Design tab of the Report Designer appears. 4. ClickFieldExplorer on the Standard toolbar. The Field Explorer dialog box appears. Note: Depending on how it appeared when you last used Crystal Reports, the Field Explorer dialog box might be docked or in floating mode. For more information about docking explorers, see Opening and docking explorers. 27 2012-03-14Quick Start 2.3.2.2 Report sections The Design tab is divided into five sections: Report Header (RH), Page Header (PH), Details (D), Report Footer (RF), and Page Footer (PF). If at any time you are unsure of the report section in which you are working, simply look at the shaded area to the left of the report which always displays either the section names or the initials that designate the names. See Design tab. If the Short Section Names check box is selected in the Design View area of the Options dialog box, then the Report Header, Page Header, Details, Report Footer and Page Footer section names will appear as RH, PH, D, RF and PF respectively. If this check box is not selected, follow these steps: 2.3.2.3 Inserting a field You'll use the Field Explorer dialog box to insert database fields when you create a new report. This dialog box is set to remain on-screen until you close it. All the tables available for use are listed in this box. You will now start placing objects on the report by inserting the Customer Name field. 2.3.2.3.1 To insert a field 1. Expand theDatabaseFields node in the Field Explorer dialog box and expand a table. 2. Highlight a field name by clicking the name once. When you highlight a field name, you can review a subset of the values for that field as well as the field type and size by right-clicking the field and selecting Browse Data from the shortcut menu. 3. Click theCustomerName field and drag it into theDetails section of the report. 28 2012-03-14Quick Start An object frame appears with the Arrow cursor as you drag the field onto the report: • The object frame represents the object you have just selected for placement. • The size of the object frame approximates the size of the data in the field selected. 4. Move the object frame as far to the left as you can in the Details section. If you move the field too far to the left, the Arrow cursor turns into a Stop cursor, indicating that you cannot drag the field that far. Keep in mind that you cannot place any objects outside the page margin. The Design tab should look similar to this: 2.3.2.4 Understanding fields Before going any further, take a look at the field you just placed in the Details section: • First of all, the object frame indicates that when the report is printed, a field value will appear where the box is positioned. • If you haven't selected the Show Field Names check box on the Layout tab of the Options dialog box, the object frame contains Xs to indicate that the database field contains a text string. Other data types have different character representations. For example, a currency data type is represented by 55,555.56. • If your report is not showing field names, the number of Xs in the object frame is the data width, the maximum number of characters in the field as defined by the database. Whether or not your report shows field names, the width of the object frame is the field width (the amount of space allocated to the field for printing). Initially it is set to the width needed to display the maximum number of characters in the field (using the font selected for the field). You can change this width by resizing the field. • The size of the characters or Xs indicates the point size selected for the characters in the field. 29 2012-03-14Quick Start • The font and style (Bold, Underline, and so on) used in displaying the characters or Xs indicate the font and style selected for the characters in the field. Later in this tutorial you will learn how to make changes to these properties. • The line spacing is adjusted to the point size selected for the characters in the field. 2.3.2.5 Adding additional fields Next, you will insert two additional fields in the report. This time, however, you will use theCtrl-click combination to add them at the same time. 2.3.2.5.1 To add additional fields 1. Highlight theCity field in the Field Explorer dialog box, press theCtrl key on your keyboard, and then highlight theCountry field. Release theCtrl key. If you scroll through the field list, you will notice that both fields remain selected. Note: Using the Ctrl-click combination allows you to select a non-continuous range of fields. The Shift-click combination can be used to select several fields from the list that are contiguous. 2. Drag the fields to place them. As the cursor is moved over the report, an object frame appears along with the Arrow cursor. 3. Place the fields to the right of theCustomerName field. Both fields appear in the Details section of the report in the same order in which they are listed in the Field Explorer dialog box. 2.3.2.6 Selecting fields When a field is selected, the object frame appears with a handle (box) on its right, left, top, and bottom edge. These handles indicate that the field is selected, and therefore active. To do anything with a field (change the font, move it, and so on), you first have to select it: • Position the cursor inside the object frame and click once. The handles appear, indicating the object is selected. • Move the cursor away from the object frame and click in an empty part of the window. The handles disappear. That's all it takes to select and deselect objects. 30 2012-03-14Quick Start 2.3.2.7 Resizing fields To resize the field, follow these steps: 1. Click theCustomerName field in the Details section to select it. 2. Press theCtrl key and click the field heading to select both objects. 3. Move the cursor over the resizing handle on the right edge of the fields until the cursor turns into a Resizing cursor. 4. Resize the fields to the right until they are approximately two inches in length. 2.3.2.8 Reviewing your work Now let's see how the report looks with three fields placed and positioned. 1. ClickPrintPreview on the Standard toolbar to activate thePreview tab. The screen should look similar to this: Note: The first time you preview a report, you must click Print Preview on the Standard toolbar to activate the Preview tab. The Preview tab appears to the right of the Design tab. You can then switch between designing and previewing the report by clicking the corresponding tab. You have the beginnings of a customer list report, but you still have several fields to add. 31 2012-03-14Quick Start 2. When you are finished reviewing the report, return to theDesign tab by clicking it. 2.3.2.9 Displaying field names Field pictures (object frames containing character representations) have been discussed, but there may be times when you want to see the field names in the Design tab. 2.3.2.9.1 To display field names 1. On theFile menu, clickOptions. The Options dialog box appears with the Layout tab active. 2. Select theShowFieldNames check box and clickOK. Now in the Design tab you will see the actual field names instead of character representations (X, , , and so on). 2.3.2.10 Combining database fields in a text object Instead of adding the Contact First Name and Contact Last Name fields as separate objects, you can insert both fields in a text object. This allows you to control the formatting of both fields by making changes to only one object. When you insert fields in a text object, the fields are automatically trimmed (they do not have any extra white space on either side). This is important because a field is a fixed size but the data in the fields can vary in size, leaving various amounts of unwanted white space. 2.3.2.10.1 To combine fields in a text object 1. ClickInsertTextObject on the Insert Tools toolbar. As you move the cursor over the report, an object frame appears next to it. 2. Insert the field to the right of the fields in theDetails section. As you drag the field, the Design tab automatically scrolls to the right, if necessary. When you click to place the object, a text object appears and the horizontal ruler of the Design tab changes to a ruler/tab selector that is used for editing the text object. If you click an empty area of the report or a field object, the standard Design tab ruler appears. 3. Click once on the border of the text object to select it for resizing. Handles appear on all sides of the object. 4. Move the cursor over the right sizing handle of the text object and increase the width by about 1 inch. You may need to scroll to the right and continue resizing. 32 2012-03-14Quick Start 5. Double-click inside the text object to select it for editing. Notice the insertion point is now flashing within the text object. 6. Select theContactLastName field in the Field Explorer dialog box. Remember, you can move the Field Explorer dialog box by dragging and dropping it by its title bar. 7. Drag the field to the text object. 8. Move the cursor over the text object until the cursor becomes a Drag and Drop cursor. 9. Release the mouse button to place the field in the text object. The cursor now appears after the ContactLastName field, within the text object. 10. Type a comma and a space afterContactLastName. 11. In the Field Explorer dialog box, highlight theContactFirstName field. 12. Drag the field to the text object. 13. Move the cursor over the text object until the cursor becomes a Drag and Drop cursor. Move the cursor to the right of the comma and space you just typed, and release the mouse button. The field will be inserted to the right of the comma and space. 14. Click thePreview tab to look at the fields you just placed. The report should now look similar to this: 2.3.2.11 Adding summary information The next step is to add summary information to your report. Adding summary information allows you to specify the author, title, and subject of the report, as well as any keywords or comments related to the report. When you add summary information, users can find information related to the report quickly. 2.3.2.11.1 To add summary information 1. On theFile menu, clickSummaryInfo. The Document Properties dialog box appears with the Summary tab active. 33 2012-03-14Quick Start 2. Enter information about your report in the text boxes provided. Be sure to enter the title "Customer List" in theTitle text box. This information will be used in the next section of the tutorial. 3. ClickOK when finished. 2.3.2.12 Adding a title As you can see, the report looks incomplete without a title. Although you can add a title using a text object, you can also tell the program to take the title information directly from the Title text box in the Document Properties dialog box. 2.3.2.12.1 To add a title 1. Click theDesign tab. 2. In the Field Explorer, scroll down toSpecialFields and expand it. 3. ChooseReportTitle. 4. Drag the cursor over the report. An object frame appears. 5. Position the object frame in the upper left-hand corner of the Page Header (PH) section of the report and release the mouse button to place the object. 6. Click thePreview tab orRefresh to review your changes. The report title object now displays the title that you entered in the Title text box of the Document Properties dialog box. 34 2012-03-14Quick Start 2.3.2.13 Formatting objects Now you can format the report title. This time, however, you will remain in the Preview tab to do the work. This will make it easier to see your work while you are formatting the title. 2.3.2.13.1 To format an object 1. To center the title, you will first need to expand theTitle field so that it's about the same width as the data in your report. To do this, select the object by clicking it. 2. Position the cursor on the right edge of the object until the cursor turns into a Resizing cursor. Drag the right edge of the field box until it is even with the right edge of the data in theContactName field object. You have created a large field that extends from the left edge to the right edge of the report. 3. With the report title object still selected, clickAlignCenter on the Formatting toolbar. The title is centered within the object. 4. Right-click the object and chooseFormatField from the shortcut menu. 5. When the Format Editor appears, click theFont tab. 6. Set the report title to a larger, bolder version of the active font by selectingBold from theStyle list and16 (or a point size suitable to the font you are using) from theSize list. 7. Change the color of the text by selectingMaroon from theColor palette. Notice that the Sample box shows an example of how the text will look. 8. ClickOK when finished. 9. Resize the report title object vertically to accommodate the increased size of the title. The title is now formatted to stand out on the report. 35 2012-03-14Quick Start 2.3.2.14 Adding a field heading As you can see, the Contact Name field is the only field without a heading. In this section you will create a heading. 2.3.2.14.1 To add a field heading 1. ClickInsertTextObject on the Insert Tools toolbar. 2. Insert the text object in thePageHeader section directly above the Contact Name field. 3. ClickUnderline on the Formatting toolbar, and then typeContactName into the text object. 4. Click your cursor outside the text object. The Contact Name field now has a heading that looks just like the other field titles. 2.3.2.15 Saving the report 1. ClickSave on the Standard toolbar to save your work. Since this is the first time you are saving the report, the Save As dialog box appears displaying the default directory where the file will be saved. Notice that a default file name, based on the report title you defined earlier, is also displayed. 2. Type Custlist.rpt in theFilename box and clickSave. Your report is saved to the default directory or another directory you chose. 3. Click thePreview tab to view the report. The report should now look similar to the following: 36 2012-03-14Quick Start Congratulations You have just created a basic listing report. You will continue to refine this report throughout the rest of this tutorial. 2.3.3 Record Selection Crystal Reports allows you to limit or restrict the records that are to be included in a report. In this section you will learn how to: • Select the records you want included in the report. • Save a report, including the selection criteria. For example, it may be useful to have a customer list that only lists customers from the USA. The sample data contains records from the United States and International customers. It is easy to restrict lists like this using the Select Expert. 2.3.3.1 Entering the selection criteria When you scroll through the report, you will see that it contains information for customers from many different countries. In this step, you will limit the number of countries displayed to the USA. 2.3.3.1.1 To enter selection criteria 1. To begin, click theDesign tab to return to design mode. 2. Click an empty area of the report to make sure all fields are deselected. 3. ClickSelectExpert on the Expert Tools toolbar. 37 2012-03-14Quick Start The Choose Field dialog box appears. This dialog box lists all the fields currently in the report in the Report Fields section and then lists all fields that are available from each table in the database fields section. 4. Since you are going to base record selection on the country field, select Country in theFields list and clickOK. The Select Expert appears. Imagine that you are completing the following sentence: Selectallrecordswhereacustomer'scountryis You complete the sentence with the condition you want the program to use when selecting records for your report. Right now the condition is any value, which implies there is no restriction on the record selection. 5. Click the arrow on the operators box to see what other options you have. Since you want only those records where the Country is USA, select theisequalto condition. A new box appears on the right. The dialog box sentence now reads: Selectallrecordswhereacustomer'scountryisequalto 38 2012-03-14Quick Start All that you need to complete the sentence is the value USA. 6. Click the arrow on the empty list. A list of all the country values appears. SelectUSA from the list. The sentence now reads: Selectallrecordswhereacustomer'scountryisequaltoUSA 7. ClickOK to return to theDesign tab. 8. Click thePreview tab to review the results of your work. The Change In Record Selection Formula dialog box appears. 9. ClickRefreshData. 10. Save this version of the report without overwriting the original report by choosingSaveAs from the File menu and giving the new report the name USA.rpt. Congratulations You have started formatting your report and have added selection criteria to it. More than that, you have learned how to manipulate your data. By now, you have a good idea of the powerful kinds of reports you can prepare. 2.3.3.2 Deleting a field Now that the report contains only records from the USA, displaying the Country field in the body of the report is not necessary. You can delete this field before continuing. 2.3.3.2.1 To delete a field 1. Select theCountry field and theCountry column heading using theCtrl-click combination. 2. PressDelete on your keyboard. That is all it takes to delete fields from the report. The report should now look similar to this: 39 2012-03-14

Advise: Why You Wasting Money in Costly SEO Tools, Use World's Best Free SEO Tool Ubersuggest.